PROBLEM:
When you use Casper to begin a copy in Windows 7 or Windows Vista, you receive an error similar to the following:
A problem was encountered with the operation of the Volume Shadow Copy Service. The copy was aborted.
CAUSE:
Casper will report this error if it is unable to create a volume snapshot because of a problem with the operation of Microsoft’s Volume Shadow Copy service infrastructure or COM+ Event System service. Volume Shadow Copy Service (VSS) failures can be caused by many things, including insufficient disk space, intermittent disk and paging I/O errors, or a problem with the registration of one or more VSS or COM components on the system.
RESOLUTION:
The first step in diagnosing the problem is to check for errors and/or warnings logged in the Windows System and Application event logs.
Follow this procedure:
-
Click Start
-
Click Control Panel
-
If viewing by Category, click System and Security, and then click View event logs appearing under Administrative Tools. (If viewing by Large/Small icons, click Administrative Tools, and then double-click Event Viewer.)
-
Under Event Viewer (Local), double-click Windows Logs to expand the folder
-
Under Windows Logs, click the Application tree and review the events there. Look for items related to VSS, COM+, EventSystem, MSDTC, etc.
-
Under Windows Logs, click the System tree and review the events there. Look for items related to Disk, VolSnap, Service Control Manager, NTFS, or controller problems.
If you see
Disk errors or warnings, especially paging I/O warnings, you should perform a surface analysis via chkdsk on the system and paging drives. This will check for and mark out any bad areas on the disk(s).
Follow this general procedure:
-
Open Computer
-
Right-click on the drive to scan and select Properties
-
Click the Tools tab.
-
In the Error-checking box, click Check Now.
-
In Check disk options, check the Automatically fix file system errors and Scan for and attempt recovery of bad sectors check boxes.
-
Click Start.
-
Repeat for all volumes to be scanned (particularly any which host Windows system files and/or Windows paging files)
If the disks appear to be fine, and in the absence of any more specific help from events logged in the Application and/or System Event Logs, you can try re-registering the volume shadow copy service and its related components.
Follow this procedure:
-
Right-click this link and select Save Target As
-
Save the file to your desktop as REREGVSS.BAT
-
Right-click on the REREGVSS.BAT file appearing on the desktop and select Run as administrator to run it
-
When the batch file has finished, restart the computer: Start -> Shutdown -> Restart
Please note that the batch file was written to support multiple platforms. Some steps may return an error or reference files not available on your particular system. Also, note that it may take several minutes to complete.
THIS ARTICLE APPLIES TO:
Article ID: 4, Created: May 6, 2010 at 9:24 AM, Modified: October 23, 2011 at 9:24 PM